Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2025 - 14:00 BST
Scheduled
We expect this update to be brief. While the downtime should be minimal, we have scheduled a maintenance window of 2 hours (from 2:00 pm to 4:00 pm). During this time, you may experience an outage of Care Control for no more than 10 minutes. If the outage exceeds 15 minutes, please contact support.
Posted May 16, 2025 - 09:24 BST
This scheduled maintenance affected: Care Control Databases, Cloud Apps (Care Planning, Admin, HR, Insights, Org Management, Roster, Consolidated Invoicing, CRM and Payroll), and Device Applications (Pocket, Mobile, eMAR, Screens, and Academy).