Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 05, 2025 - 09:21 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 05, 2025 - 09:21 BST
Scheduled
We’ve been informed by NHS England that GP Connect may be unavailable between 9:00am and 12:00pm on Wednesday the 5th of June due to scheduled maintenance. Please note, this is not an issue with Care Control – the downtime is part of NHS England’s system maintenance.
Posted Jun 05, 2025 - 09:20 BST
This scheduled maintenance affected: Cloud Apps (Care Planning, Admin, HR, Insights, Org Management, Roster, Consolidated Invoicing, CRM and Payroll).