Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 16, 2024 - 05:00 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 12, 2024 - 16:58 BST
Scheduled
We will be performing essential maintenance on our Care Control databases. During this time, there will be a 10-minute period where our Cloud Apps, Device Applications, and Care Control Windows application will be unavailable.
Posted Jul 12, 2024 - 16:56 BST
This scheduled maintenance affected: Care Control Databases, Cloud Apps (Care Planning, Admin, HR, Insights, Org Management, Roster, Consolidated Invoicing, CRM and Payroll), and Device Applications (Pocket, Mobile, eMAR, Screens, and Academy).